To stop the reverse engineering of script applications, a number of developers encrypt their code with instruments such as ionCube PHP Encoder to make it human unreadable. The latter is valid for paid apps in particular, as anybody would be able to use and change the unencrypted code without having to pay the necessary license fees. If you buy web software protected with ionCube PHP Encoder, you'll be able to use it without a problem as long as a software instrument called ionCube Loader is a part of the website hosting server. This loader allows you to run encoded files and you will often see it among the prerequisites for a certain script application to be set up. As the encrypted files are already precompiled, they're usually executed faster and this will improve the general speed of your site.
IonCube in Shared Hosting
IonCube Loader is available with all of the shared hosting packages which we supply, so any time you require it in order to set up and run some script application that needs it, you can enable it with a click in the Advanced section of the Hepsia Control Panel. As you are able to switch the PHP version that is active for your account in the same section, you need to activate the instrument for any new version that you set. If you are more experienced, you are able to use a php.ini file in a domain or subdomain folder and set the PHP version as well as the status of ionCube Loader for this particular site only, without affecting the entire account. This way you'll be able to operate both new and older script apps for multiple sites within the same account - something that you will not be able to do with various other website hosting suppliers out there.
IonCube in Semi-dedicated Servers
If you aquire a semi-dedicated server plan from us, you will be able to employ any kind of script-driven app that requires ionCube Loader since the software tool is installed on all the servers that are a part of our cutting-edge cloud web hosting platform. In addition, we support multiple versions of PHP, so if you switch from PHP 4 to 5.2 or 5.3, for example, you can activate ionCube for this particular release with just a click from your Hepsia Control Panel. Our system will remember your choice, so in case you switch back to the previous version of PHP, the software tool will already be active. For more tech-savvy users, we also provide the option to select the PHP version and if ionCube will be active or not for a specific domain name without altering the settings for the whole web hosting account. This can be done by placing a php.ini file in a domain folder with a few lines of program code.